
Sequence Clip Reporter
Sequence Clip Reporter creates an Excel spreadsheet report about the video clips, audio clips 
and markers you've used in your edited sequence or bins. The report includes sheets for:

• Clips, 
• Sequence Markers, 
• Clip Markers
• Generators
• Transitions
• Clip Filters
• Motion Tab settings 
• Files Summary and Reels Summary
• Reels.

You can choose which tracks of clips to include in the report, and Preferences lets you choose 
whether durations are reported as seconds (for easier spreadsheet calculations), frames or 
HH:MM:SS:FF timecode format.

Please use Email Support under the Help menu for bug reports, feature requests or support.

Loading your sequence into Sequence Clip Reporter
1. Open your project and your sequence if it isn’t already open in your editing 

application.
2. Choose the File menu and select Export > XML… (Final Cut Pro) or Export > Final 

Cut Pro XML… (Premiere Pro).
3. In Sequence Clip Reporter, click the Open XML file… button or choose the File 

menu and select Open... to open the exported XML; or drag-and-drop the XML file 
to the dock tile.

4. To switch to another sequence, open it in your editing application and export a new 
XML file for opening into Sequence Clip Reporter.



Analyzing your Bins or Sequences
1. In Sequence Clip Reporter choose the sequence (or Bin Clips) you want to analyze 

from the Report popup menu, then click the Analyze button; or, if your project has 
only one sequence or only bin clips, it is automatically analyzed for you.  
Tip: If you need to report video only or audio only, you can set a preference to 
analyze only the track types you want (see Preferences). Analyzing only video or 
only audio is faster than analyzing both.

2. Click the checkboxes 'on' 
for each video and audio 
track you want to include in 
the report.

3. To leave out audio in clips 
that also contain video, 
click the Ignore audio in 
clips with video checkbox 
'on'.

4. To add optional information 
to the report for 
thumbnails, markers, titles, 
transitions, filters, motion 
effects or reels, click the 
appropriate checkboxes 
'on'.

5. If you want the spreadsheet 
to open after the file is 
saved, click the Open the 
spreadsheet after saving 
checkbox 'on'.

6. Click the Save 
spreadsheet… button. 
Name and save the 
spreadsheet.

The spreadsheet can then be 
rearranged and customized, or the 
content of the spreadsheet copied 
and pasted into a pre-made template.

You can create reports for another 
sequence in your project by selecting 
it from the Sequence popup menu 
and clicking the Analyze button.



IMPORTANT: Nested sequences and their clips are ignored.

Clips Report
Lists the video and/or audio clips for the chosen tracks in order of their appearance 
(regardless of which track the clip is in). The report includes columns for: Thumbnail; Track 
or Bin; Clip Name; Enabled; Sequence In timecode; Sequence Out timecode; Clip Duration 
(calculated from Sequence In/Out timecode); Source Reel Name; Source In timecode; Source 
Out timecode; Source Duration (calculated from Source In/Out timecode); Sound Roll Name; 
logging information (Description, Scene, Shot/Take, Log Note, Scene Note, Shot Note, 
Take Note); film data (Camera Roll, Daily Roll, Lab Roll); Label; comments (Master 
Comment 1, Master Comment 2, Master Comment 3, Master Comment 4, Comment A, 
Comment B); Frame Rate/Sample Rate; Frame Size; Source File Path.

Sequence Markers Report
Lists the sequence markers in order of their appearance. The report includes columns for: 
Marker Name; Type (Note, Chapter, Compression or Scoring); Comment; Start timecode; 
End timecode; Duration; and Color.

Clip Markers Report
Lists the clip markers in order of their appearance (regardless of which track the clip is in). 
The report includes columns for: Track; Marker Name; Clip Name; Comment; Color; 
Sequence In and Sequence Out timecodes; Duration; Source In and Source Out timecodes.
IMPORTANT: Premiere Pro CS6 (but not CC) has an issue that prevents markers being 
exported into the Final Cut Pro XML, so sequence and clip markers cannot be reported.



Graphics & Titles Report
Lists the generators in the chosen video tracks. The report includes columns for: Track; Clip 
Name; Text Generator; Sequence In timecode; Sequence Out timecode; Duration; Font; and 
the Text content entered for the title.

Transitions Report
Lists a summary of the Apple and Third-party transitions used and the transitions in the 
chosen tracks. The report includes columns for: Track; Transition name; Sequence In 
timecode; Sequence Out timecode; and Duration. Third-party transitions are highlighted 
with red text. 

Clip Filters Report
Lists a summary of the Apple and Third-party filters used and the filters applied to video 
and/or audio clips for the chosen tracks. The report includes columns for: Track; Filter 
name; Enabled; Clip Name; Sequence In timecode; Sequence Out timecode; and Duration. 
Third-party filters are highlighted with red text.



Motion Effects Report
Lists the Motion effects applied to video clips for the chosen tracks. The report includes 
columns for: Track; Motion setting name; Clip Name; Sequence In timecode; Sequence Out 
timecode; and Duration.

Files Summary Report
Lists all the media files used in the sequence, the estimated total duration of material used 
from each file, and the percentage of total material used from each file. The report includes 
columns for File Name; File Path; Estimated Total; and % of Total.

Reels Summary Report
Lists all the reels used in the sequence, the estimated total duration of material used from 
each reel, and the percentage of total material used from each reel. The report includes 
columns for Source Reel Name; Estimated Total; and % of Total.

Reels Reports
A report sheet is created for each source reel for clips in the chosen tracks. Each sheet lists 
the video and/or audio clips for the chosen tracks in order of their appearance (regardless of 
which track the clip is in). The report includes columns for: Track or Bin; Clip Name; 
Enabled; Sequence In timecode; Sequence Out timecode; Clip Duration (calculated from 
Sequence In/Out timecode); Source Reel Name; Source In timecode; Source Out timecode; 
Source Duration (calculated from Source In/Out timecode); Sound Roll Name; Source File 
Path; logging information (Description, Scene, Shot/Take, Log Note, Scene Note, Shot 
Note, Take Note); film data (Camera Roll, Daily Roll, Lab Roll); Label; comments (Master 



Comment 1, Master Comment 2, Master Comment 3, Master 
Comment 4, Comment A, Comment B); Frame Rate/Sample 
Rate; Frame Size; Source File Path. An Estimated Total for 
Source Duration is included at the bottom of the Source Duration 
column.

Filtering reports in Excel
Excel has powerful features for filtering a spreadsheet. 

1. In Excel, choose the Data menu, and from the Filter 
sub-menu select AutoFilter. A popup menu indicator 
is added to the headings of the frontmost sheet.

2. To show only those rows where, say, Master Comment 
1 is “Algonquin Hotel”, click the Master Comment 1 
popup menu indicator and select Algonquin Hotel 
from the menu. The spreadsheet changes to show only 
those rows with Algonquin Hotel in the Master 
Comment 1 column.

3. For more powerful filtering, choose Custom Filter… 
from the popup menu. The Custom AutoFilter dialog 
opens. (See Excel’s help topic “Filter a list of data” for 
more information.)

Preferences
Choose the Sequence Clip Reporter menu and select Preferences to open the Preferences 
window.

Layouts
You can create Layouts for clip reports 
that include only the columns you 
have selected. 
Click the “plus” button to name the 
new layout and add it to the popup 
menu, then turn on the checkboxes 
for the columns you want to include in 
the reports.

Click the “pencil” button to rename 
the layout; click the “minus” button to 
remove the layout. 
The default layout is Standard, which cannot be renamed or removed.



You can choose to Add thumbnails at pre-set width or a custom width. The thumbnail image 
is created from the clip’s in point. Thumbnail images can only be created from QuickTime/AV 
Foundation-compatible media that is online. If the media is offline or incompatible, the 
thumbnail will be a “Missing” or “Unknown” graphic. Layouts that include a column for 
thumbnails will be significantly slower to create. 
Tip: Sequence Clip Reporter running on Mac OS X 10.10 or later supports more media types 
(via AV Foundation) if the free “Pro Video Formats” are installed from this search page. You 
can check if you have Pro Video Formats installed by choosing Help > Check for Pro Video 
Formats.

Importing
You can choose whether to import both video and audio tracks, only video tracks, or only 
audio tracks. Importing just video or audio tracks is faster than importing all tracks.

Time Display
You can choose whether times are reported 
as Frames, Feet+Frames (4-perf at 24 
fps), HH:MM:SS, Seconds, or HH:MM:SS:FF 
timecode format (drop frame or non-drop 
frame timecode will be used depending on 
the clip or timeline setting), or a 
combination of these.
One or more time columns can be added to 
the report, and sequence times can be 
reported differently than source times.
For Sequence In and Sequence Out you can 
apply frame offsets to the reported times.

Text Colors
You can choose to have the spreadsheet rows for video clips, audio clips and markers set to 
different colors. Excel has 15 different colors available.

Updates
Use the Check at Launch checkbox to choose whether to automatically check for software 
updates. You can manually check for software updates by clicking the Check now button, or 
by choosing the Sequence Clip Reporter menu and selecting Check for Updates… Checking 
for software updates occurs only when you are connected to the internet. 
The latest version of Sequence Clip Reporter can also be downloaded from any internet-
connected computer by visiting www.AssistedEditing.com/downloads.  

https://support.apple.com/kb/index?page=search&q=%22pro%20video%20formats%22&currentPage=1&includeArchived=false&locale=en_US&src=globalnav_support&type=suggested
http://www.AssistedEditing.com/downloads/


Activating Sequence Clip Reporter
After you install Sequence Clip Reporter onto a computer, it will need to be activated with a 
License Key before it can be used. Each License Key can be used to activate only one 
computer at a time. If you want to activate the software on another computer, you’ll need to 
deactivate it first. See Moving Sequence Clip Reporter to another computer for details.
You’ll temporarily need internet access for the activation so that the software can connect to 
our server and confirm the License Key.

• When the software is first run it will display a Software License Agreement. Scroll 
down to read through the license agreement and click the I Agree button at the 
bottom of the page.

• Enter the License Key that was given to you and click the Activate button. The 
software will send the License Key to our server for confirmation.

• You’ll get a message in green saying that you’ve successfully activated your license. 
Click the Continue button.

If the software could not be activated with the License Key, you’ll get a message in red 
explaining the reason, such as:

• This is not a valid License Key — check to make sure you have entered the License 
Key correctly;

• This is not a License Key for Sequence Clip Reporter — make sure you’re entering a 
License Key that can be used to activate Sequence Clip Reporter;

• The License Key has already been activated — if you want to activate Sequence Clip 
Reporter on this computer you'll need to deactivate the other installation before 
activating this one, or purchase another License Key.

Moving Sequence Clip Reporter to another computer
To move Sequence Clip Reporter from one computer to another, you'll deactivate it on the 
first computer, then activate the installation on the second computer.
To deactivate the software on one computer and activate it on a different computer, both 
computers will temporarily need internet access.

• On the first computer, choose Deactivate from the application menu.
• Confirm that you want to deactivate the software by clicking the Deactivate button.
• You’ll receive a message in green saying that you’ve successfully deactivated your 

license.
• On the second computer, run Sequence Clip Reporter, and follow the instructions for 

Activating Sequence Clip Reporter.
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